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Plutext Walkthrough 

This is a short guide to what it is like to use Plutext for collaboration.  It is designed to allow you to 

follow along on your computer if you wish.   

It starts with the basics, and works up towards the more powerful features. 

This guide is intended as an alternative to the videos on our website, for people who prefer instructions 

in a single document. 

INTRODUCTION 
Plutext is an add-in for Microsoft Word, which enables you to work on a Word document with your 

associates at the same time.  Changes you make are reflected in other people’s copies, and vice versa. 

With Plutext, you avoid having to either take turns to access the document, or reconcile changes in the 

various copies of the document people have made. 

If several people are trying to finish a document before a deadline, this can be a life saver. 

As you will see later in this document, Plutext includes powerful features to help everyone understand 

how the document has changed over time.  You can drill down to see all the changes made to any 

specific part of it. 

GETTING STARTED 
To use it, you need 2 things: 

1. Our add-in installed in Word 2007 

2. Access to a Plutext server 

Installing the add-in 

Preequisites 

Word 2007. 

(If you do not have Word 2007, you can use docx4all, which also works on Mac OSX.  Please see 

dev.plutext.org for further details.) 

Steps 

1. Visit http://dev.plutext.org/downloads/setup.exe 

2. Run the installer 

3. Start Word; Go to the Review Ribbon; and verify that it contains the following items: 

http://dev.plutext.org/downloads/setup.exe
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Access to a Plutext server 

Please see page 4. 

WORKING ON A SHARED DOCUMENT 
In this section, you’ll make some changes to a pre-existing shared document. 

Documents can behave differently depending on how they were set up.  There are two dimensions to 

this: 

1. Content control size 

 

When you make a change to a plain vanilla Word document and save it, Word saves the entire 

document.  Even though, to you, the document is made up of paragraphs and perhaps chapters, 

sections and sub-sections (or clauses), to Word, it is just one big blob. 

 

Word 2007 has a feature called content controls. A content control is an identifiable piece of 

content.   



  
Page 3 

 
  

The screenshot below shows a content control surrounding clause 4.5: 

 
1 

 

When you click inside a content control, the blue box delineates it.   The text inside the content 

control is ordinary Word document content; the blue box does not appear when you print the 

document. 

 

Plutext uses this feature to manage the content of the document at a more granular level than 

the traditional “document-is-a-file”. 

 

At its simplest, you can make each paragraph into a content control.  If you have headings or 

clauses or sections in your document (as in the example above), you might want content 

controls which match these topics. 

  

2. Reasons for change 

 

Plutext can be configured to prompt whenever you save changes, to describe the change.  This is 

useful information for the people you are working with, and might be useful down the track if 

questions are asked about why the change was made. 
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This gives 4 combinations, as shown here: 

  Reasons for Change 

  No prompt User can describe 

Content 
controls 

 Each paragraph is a 
content control 

See 
Express Document 

 below 

 

Content controls 
contain the 
paragraphs relating to 
some topic 

 See 
Structured Document 

 below 

 

In this walkthrough, we look at sample documents set up in the 2 most common configurations: 

 One paragraph per content control; save without prompting for reason – what you might call a 

express setup 

 Topic per content control; prompt for reasons – structured setup 

But first, you need to point Word at the server containing these sample documents. 

Accessing a Plutext server 

Preequisites 

You have downloaded/installed the Plutext Add-In for Word 2007 (see page 1). 

(If you do not have Word 2007, you can use docx4all, which also works on Mac OSX) 

Steps 

1. Start Word 

2. Go to the Review Ribbon 

3. Click File > Settings, and fill out the dialog as per the screen shot below.  The password is 

“tester”. 
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4. You can click “Test Connection” to ensure you are able to talk to our server. 

 

Express Document 

Here we open an existing shared document. 

To do this: 

 On the Review Ribbon, select File > Open shared docx 

 

Then, in the dialog that pops up: 
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 Select “demo.docx” and press the Open button. 

The document will open.  It may look something like: 

 

(other users may have changed it since this screenshot was taken). 

Now you can make changes / edit this document as you normally would. 

When you are ready to share your changes with other users, press “Transmit My Edits” on the Review 

Ribbon: 

 

This will transmit the contents of any altered content control to the server. 

When you are finished, simply close the document.  You save your changes by pressing the transmit 

button: there is no need to use Word’s File > Save dialog (if you do press File > Save, you will be saving 

to your temporary local copy of the document, not to the shared copy on the server). 
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You can get other people’s updates by pressing “Fetch Remote Edits” 

 

However, the chances are that nobody else has updated the document since you opened it. 

To see what happens when someone else has made changes, you can simply open a second copy of the 

document on your computer, and arrange the windows like so: 

 

This way, you can make a change in the left hand document and press the Transmit button, then in the 

right hand document, press Fetch to see it. 

Conflict Handling 

What happens when two users try to change the same paragraph? 

The answer is that the first person to Transmit their change has theirs saved to the server.   

If the other user presses the “Fetch” button, the remote changes will be automatically merged with their 

local changes and displayed in their document using Word’s tracked changes. 

If this other user had instead tried to Transmit (ie save) theirs without having first fetched the available 

update, they will be told that they can’t save theirs until they have fetched the updates. 

It is up to this second user to to review the tracked changes (ie accept or reject them).  Once they have 

done this, they will be able to “Transmit” the result.  The rule is that you can’t transmit a piece of 

content which contains tracked changes. 



  
Page 8 

 
  

Overview of Recent Changes 

Because each change to a content control is saved as a new version of that content control, there are 

several ways to get an overview of how the document has changed. 

You access this functionality from the Audit button on the Review ribbon: 

 

Here we look at what “Recent Changes” does.  When I pressed it, this was the result: 

 

You can see that this document contains some tracked changes. 

What is it?  This is a new document, in which each paragraph is the result of comparing the current 

version with the most recent previous version.  So it is a bit like comparing 2 Word documents – in the 

old world, the current version of the document compared to the previous version. 

In summary, the objective of “Recent Changes” is to give you a quick overview of what changes have 

been made to the document. 

Structured Document 

Again, we are opening an existing shared document; this time though, its the document in the 

screenshot on page 3.  This document contains content controls matching the clauses (rather than just 

one per paragraph), and when the user presses Transmit, it prompts  them to type the reason for their 

change. 
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The beauty of this is that, with your cursor inside a content control, if you click “Version History” (from 

the Audit Button on the Review Ribbon), you will see a new document containing a chronological history 

of that piece of content.  Here is what that looks like: 

 

Notice: 

 The description of each change (below the version number) 

 Who made the change (tester@public in this case), and when 

 The redlining indicating the change 

If you wanted to revert to one of these earlier versions, you can simply copy the text into the document 

you are working on.  The formatting will be retained. 

To see this example for yourself: 

 On the Review Ribbon, select File > Open shared docx, then choose legal-uk-short.docx 
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The screenshot above is the result of clicking into clause 5.3, then choosing Audit > “Version 

History” from the ribbon. 

SHARING YOUR OWN DOCUMENT 
You are welcome to experiment making changes to any of the documents you see on the server. 

You are equally welcome to try sharing a document of your own – and here we explain how to do that.  

Please be aware though, that the public at large will be able to see it and edit it, unless you set up your 

own “private space” as explained in the next section. 

To share your own document, you: 

 put content controls in it,  

 save it to the Plutext server, 

 invite others to collaborate 

Adding Content Controls  

The first step is to split the document up into content controls.  These are the “units” or atomic pieces of 

content which are stored on the server, and dynamically stitched together to create the document one 

sees in Word. 

There is a wizard which does this for you.  As the screenshot below shows, there are three ways you can 

set up your content controls: 
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1. each paragraph is a content control, 

2. you can choose to start a new content control each time certain Word styles are encountered, 

or 

3. you can manually type a less than sign (“<”) twice at the start of certain paragraphs, to indicate 

content controls should start there. 

To run the wizard: 

 open the document you want to share 

 from the “Content Grouping” button on the Review Ribbon, select “Setup Wizard” 

 
 choose one of the wizard options, and click “OK”. 

After you have run the wizard, you can fine tune the results by merging two content controls into one, 

or splitting a content control into two (see the Content Grouping menu above). 

Now you are ready to save the document to the Plutext Server. 

Saving the document to the Plutext Server 

Once you have content controls surrounding your text, you can save the document to the Plutext Server. 

To do this, simply select “New share” from the File button on the Review menu: 

 

For this to work, the add-in needs to be pointing at a live Plutext server (see Accessing a Plutext server 

on page 4 above). 

Inviting Users 

Ordinarily, your final step would be to invite the people with whom you wish to collaborate. 
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However, in this public shared space, everyone logs in as user “tester@public”.   (Instructions on how to 

invite a user are given below). 

If you wanted, you could simulate inviting a user by sending them an email with a link to: 

http://alpha.plutext.org/alfresco/plutextwebdav/User%20Homes/tester/legal-uk-short.docm 

telling them  

username: tester@public0902 

password: tester 

Note the document name here ends with “.docm”, not “.docx”.  The “.docm” form is the same 

document, except that it contains a macro which, if run, will check whether your correspondent has the 

Word add-in installed, and if not, helps them to install it.  The objective is simply to help them get 

started with a minimum of fuss. 

YOUR OWN PRIVATE SPACE 
If you want to test documents in private, or the end-to-end experience of collaborating with registered 

users, you can set up your own private space on alpha.plutext.org 

To do this, you choose a name for your space, and register it. 

You are the administrator of this space, and you can set up your users in it. 

Once you have your own space, you can add documents to it, and invite users to work on those 

documents with you. 

Registering your Collaboration Space 

 Using your web browser, visit http://alpha.plutext.org/alfresco/register.html 

http://alpha.plutext.org/alfresco/plutextwebdav/User%20Homes/tester/legal-uk-short.docm
http://alpha.plutext.org/alfresco/register.html
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 You should see: 

 
 Choose a name for your group, and a password (which you can remember), then press 

“Register”.  Please be patient, you may need to wait 20 seconds or more at this point. 

Plutext uses Alfresco as its default document repository.  Alfresco is a robust, enterprise class content 

management system, founded by a team which includes the people who developed Documentum, and 

which also happens to be open source.   

 

Setting up Users 

 Vist http://alpha.plutext.org/alfresco in your web browser 

http://alpha.plutext.org/alfresco
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 You should see: 

 
 Click on the login link at the top; login as user admin@yourgroup.com  (replace yourgroup.com 

with whatever name you chose), using the password you chose. 

 Then click the “Administration Console” icon at the top of the screen (4 icons to the left of 

“Raise and Issue”): 

 
 Choose “Manage System Users”, then “Create User” 
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 You should see: 

 
 For “Home Space Name” on the next screen, we suggest as a convention that you enter the 

value you use for “User Name” 

 Complete this “New User Wizard” for each collaborator 

 

Sharing your own documents 

Now you have your own collaboration space and registered users, you are ready to share documents. 

You or any of your collaborators can share a document by following the steps outlined in “Sharing your 

own Document” on page 10 above. 

Note that you and each of your collaborators will need to set up their Word add-in to use: 

 Their username 

 Their password 

 Workspace = The directory containing the document (ordinarily a user’s home space name, 

which will be a username if you follow the suggested convention) 
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In File > Settings on the Review Ribbon: 

 

Inviting Users 

Once you or one of your collaborators has shared a document by saving it to their directory in your 

private space on the Plutext server, you can invite users to collaborate on it: 

 On the Review Ribbon, choose Users > Invite Users: 

 
 In the dialog which pops up, press the “Search” button 

 Click on a name in the list of users, choose role “collaborator”, then press “Add to List” 

 Once you have added all the users you want, press “Next” 
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 In the resulting dialog: 

 

be sure to select “Yes”, you want to send an email to the invited users.  Click Next or Finish. 

These users will receive an email containing a link to the document. 

If they click on the link, the document will open on their PC. Provided they are running Word 2007, a 

macro will check whether they have the add-in installed, and if not, download/install  it for them. 

If the user does not have Word 2007, they can still collaborate on the document using docx4all.  

Documentation regarding docx4all is available on the plutext website. 

 

 

 

 

 

 

Warning: This service is currently in alpha testing.  It may be unavailable at any time without notice.  You 

should not trust your production documents to it.  

Please direct any feedback on our service or this document, to jason@plutext.org  

Document version 1.1; 27 February 2009 

mailto:jason@plutext.org

