Page 1 of 1

OpenDope upgrade

PostPosted: Tue Nov 26, 2013 8:54 pm
by fkfausa

Not sure whether I am posting in the correct forum, but anyway, here we go.

OpenDope was upgraded rather recently (som days ago). After the upgrade we are experiencing that OpenDope no longer recognises the customXML part of our documents. Earlier I was able to choose "Show task pane" and start working with the xml. Now "Show task pane" is not enabled and we can only choose "Add CustomXML to this docx". What has happened? Can it be fixed somehow? I really hope so or else we will be in trouble with our customers :roll: !

Re: OpenDope upgrade

PostPosted: Tue Nov 26, 2013 9:21 pm
by jason
I'll have a look at it tomorrow.

The build was floating around for a month or so - during which time nobody raised this issue - before it was put in place as an "upgrade" :-(

Re: OpenDope upgrade

PostPosted: Tue Nov 26, 2013 9:23 pm
by fkfausa
Hmmm, If I open a document, I get the trouble described. But, if I open the same document again, while the first one is open, voila, it works. Any hints on how to fix this?

Re: OpenDope upgrade

PostPosted: Wed Nov 27, 2013 10:05 am
by jason
When I first open the test docx provided by the other user in his related thread in Word, it says "Protected View This file originated from an Internet locaton and might be unsafe. Click for more details. Enable Editing"

When I click "Enable Editing" the task pane does not show up.

But if I close the document, then open it again, detection will then work correctly (ie the task pane opens).

This is the only way I can get the docx to misbehave (Word 2010: 14.0.7106.5003 (64-bit) )

What version of Word are you running?

What other add-ins are you running (File > Options > Add-Ins) ? (the addin uses Word.ApplicationEvents4_DocumentOpenEventHandler; maybe some other addin is interfering with the processing of that event)

Do you have a sample docx which isn't working for you?


I thought it might be a bitness issue, so I tried it on another computer, running Word 2010: 14.0.7106.5001 (32-bit)
but that seemed fine.

You could try uninstalling the add-in, then using ... nSetup.msi (same thing, just an msi for local distribution)


If we can't solve it, I may be able to get the older version from a server backup. But it would be preferable from my point of view to get to the bottom of the issue you are experiencing.

Your other option is to use the other newer add-in

Re: OpenDope upgrade

PostPosted: Wed Nov 27, 2013 10:25 am
by jason
Ahh, I find I can replicate your behaviour if I double click on the file in Windows Explorer.

In my previous tests, I was doing File > Open from within Word.

This post seems to explain what is going on: ... forum=vsto

"In Word 2010 the word startup behavior is changed, VSTO runtime waits for Word to be ready before firing the ThisAddIn_Startup event. And In this scenario by that time the DocumentOpen and WindowActivate events are already fired."

What it doesn't explain is why things might have worked for you before the update, and why nobody ever reported this before (given the addin is used at a number of sites) ...

Anyway, I'll now try implementing the workaround suggested in that article. Stay tuned...

Re: OpenDope upgrade

PostPosted: Wed Nov 27, 2013 2:34 pm
by jason
OK, please uninstall the existing addin (Control Panel > Programs), then try: ... /setup.exe

let me know how it goes .. thanks

Re: OpenDope upgrade

PostPosted: Thu Nov 28, 2013 11:21 pm
by fkfausa
Success!! :D :D :D :D :D

Thank you so much for your outstanding work and service.