Page 1 of 1

Docx4j 8.3.7 released for Java 8

PostPosted: Thu Jun 09, 2022 10:46 am
by jason
docx4j 8.3.7 was uploaded to Maven Central yesterday. Being in the 8.x series, minimum supported Java version is 8.0. Please note that 8.x is now a legacy branch; users are encouraged to migrate to v11.4 where active development is taking place.

8.3.7 is a recommended update for anyone using v8.3.2, v.8.3.3 or 8.3.4, since it corrects an issue preventing documents containing certain chart parts from saving.

It also brings parity with 11.4.7 (hence the .7 version number). For more details, please see https://github.com/plutext/docx4j/blob/ ... ANGELOG.md

To use docx4j 8.3.7 via Maven, just add one and only one of docx4j-JAXB-Internal, docx4j-JAXB-MOXy,
or docx4j-JAXB-ReferenceImpl to your pom. https://search.maven.org/search?q=g:org.docx4j

Otherwise, see https://www.docx4java.org/downloads.html